Jump to content

Problem z wifi na różnych linuksach .


Recommended Posts

Kilka dni temu zaczął się inny problem z wifi na laptopie ;
na windows łączy bez problemu a n a linuksach ; najpierw AV LINUX MX21 , który jest klonem debiana a w tej chwili na MANJARO - stara się nawiązać połączenie a po chwili je zrywa
i  znów na ikonce sieci kręci się kółko . Jeszcze godzinę temu na tym klonie debiana a teraz
na manjaro  , po wydaniu w konsoli polecenia ; ping 192.168.1.1 odpowiada że sieć jest niedostępna. Dlatego tego posta muszę pisać z poziomu win 11 ....
Zmiana routera z tplink 3631 na Funbox2 nie poprawiła sytuacji ....
Czy może być tak że karta wifi RTL8821CE psuje się na linuksie a nie psuje się na windows 11 ?

Link to comment
Share on other sites

Co oznacza zmiana routera? Zakładam, że ten router ma access pointa wifi i to przez niego się łączysz? Czy na pewno wszystko co odbiera karta wifi pochodzi z tego routera/AP? A może tam jest coś dalej? DHCP?

Pozdrawiam

Radek Głębicki

 

Link to comment
Share on other sites

Nie Radku , u mnie jest zawsze 1 router  , bez accespointa .

tylko gdy jeszcze kilka lat temu dostałem  do neostrady Livebox2 to ze względu na słaby zasięg wifi tego urządzenia -

kupiłem własny router adsl - TPLINK  3631 . Ma on 2 antenki , więc jego zasięg jest lepszy niż livebox2 .

Ale 2 lata temu zmienili mi livebox2 na Funbox2 . To cudo od orange też ma tylko  wewnętrzną antenkę wifi  ,

ale działa on zarówno w zakresie 2,4 jak i 5 GHZ . A router tplink-a ma tylko stary zakres 2,4 ghz .

Więc teraz używam najczęścien funbox2 a tplink jest takim tylko urządzen iem zapasowym .

 

Link to comment
Share on other sites

Winny może być dual boot, przynajmniej tak wynika z tego wpisu.  Choć z drugiej strony to na github owego modułu jest wzmianka o problemach w  oryginalnym module jądra w wersji >=5.9 i próbach jego obejścia. Jednak ten moduł (tomaspinho) jest nieoficjalny, aby go załadować należało by wyłączyć Secure Boot. Wypadało by przeczytać wnikliwie plik README przed instalacją, port LAN posiadasz ? Czasami tak jest z modułami Realtek że nie działają prawidłowo. 

Powodzenia!

To co teraz napiszę może wydawać się zbyt prozaiczne, ale być może zbyt szybo przełączasz się z Okien na Linuksa, po prostu przed uruchomieniem powinieneś odczekać jakieś 3-4 minuty. Brzmi banalnie ?

Link to comment
Share on other sites

Dla jasności to masz router z access pointem. AP jest wbudowany. Są routery bez AP i wtedy można dokupić AP i podłączyć do routera za pomocą kabla ethernet. Także mogą być routery bez switcha, więc wtedy trzeba nawet switcha podłączyć i przez switcha dopiero AP.

Dla testów pozmieniaj kanał wifi, a może typ szyfrowania. Generalnie poprzestawiaj ustawienia tego AP w routerze. Dodatkowo moje pytanie było o serwer DHCP. Czy jest on aktywny w tym routerze i czy to on odpowiada za przydzielania adresów IP. Może adresy IP są przydzielana z "zewnątrz".

Pozdrawiam

Radek Głębicki

Link to comment
Share on other sites

W routerze funbox2 u mnie wszystko idfzie z Automatu .

DHCP jest włączone cały czas ,

Wczoraj  zauważyłem że na manjaro wifi w zakresie 5 GHZ działa prawie tak samo dobrze jak na wingrozie 11.

W zakresie 2,4 GHZ jest na linuksie słabiej .

Gdy uruchomiłem live Lubuntu - wynik speedtestu był na min 4-ktotnie gorszy niż na winshicie  11.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...