Skocz do zawartości
pazdzioch23

Fedora Core 7 Nie Mogę Zainstalować Skype

Rekomendowane odpowiedzi

Czytałem różne opisy dotyczące instalacji Skype ale nic z tych podpowiedzi mi nie pomogło.

 

Yum nie może mi wyszukać wógle Skype

 yum install skype
Loading "priorities" plugin
0 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
No package skype available.
Nothing to do

 

 

Jak ściągnąem Skypa dla FC5 i prubuję go zainstalować poleceniem:

rpm -Uvh skype-1.4.0.118-fc5.i586.rpm

To wyskakuje mi coś takiego:

 

Tomek]# rpm -Uvh skype-1.4.0.118-fc5.i586.rpm

ostrzeżenie: skype-1.4.0.118-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
       libQtCore.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
       libQtDBus.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
       libQtGui.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
       libQtNetwork.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
       libsigc-2.0.so.0 jest wymagany przez skype-1.4.0.118-fc5.i586
       qt4-x11 >= 4.2 jest wymagany przez skype-1.4.0.118-fc5.i586

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Potrzebujesz QT w systeime - możesz pobrać też wersję Skype ze zintegrowanym QT.

 

A yum Skypea nie znajdzie - bo to zewnętrzne oprogramowanie i nie ma go w repozytoriach. Byłoby to sprzeczne z licencją, pomijając fakt że ten program jest śmieszny.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Potrzebujesz QT w systeime - możesz pobrać też wersję Skype ze zintegrowanym QT.

 

A yum Skypea nie znajdzie - bo to zewnętrzne oprogramowanie i nie ma go w repozytoriach. Byłoby to sprzeczne z licencją, pomijając fakt że ten program jest śmieszny.

 

Zainstalowałem.

Ale nadal nie mam tego:

 rpm -Uvh skype-1.4.0.118-fc5.i586.rpm
ostrzeżenie: skype-1.4.0.118-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
       libQtGui.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
       qt4-x11 >= 4.2 jest wymagany przez skype-1.4.0.118-fc5.i586

Tylko że tego nie mogę znaleźć.

A tego Skype ze zintegrowanym QT. nie potrafię zainstalować.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Zainstalowałem.

Ale nadal nie mam tego:

 rpm -Uvh skype-1.4.0.118-fc5.i586.rpm
ostrzeżenie: skype-1.4.0.118-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
       libQtGui.so.4 jest wymagany przez skype-1.4.0.118-fc5.i586
       qt4-x11 >= 4.2 jest wymagany przez skype-1.4.0.118-fc5.i586

Tylko że tego nie mogę znaleźć.

A tego Skype ze zintegrowanym QT. nie potrafię zainstalować.

 

Na początek spróbuj

yum localinstall skype-1.4.0.118-fc5.i586.rpm

a jak nie zadziała to

yum list qt4-x11

oraz

yum provides libQtGui.so.4

aby odnaleźć odpowiedni pakiet.

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
A próbowałeś zainstalowac najnowsze SKYPE 2.0 BETA z obsługa video :?:

Jest wersja dla fedory :rolleyes:

Próbowałem i też nic.

]# rpm -Uvh skype-2.0.0.27-fc5.i586.rpm
ostrzeżenie: skype-2.0.0.27-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e
błąd: Niespełnione zależności:
       libQtGui.so.4 jest wymagany przez skype-2.0.0.27-fc5.i586
       qt4-x11 >= 4.2 jest wymagany przez skype-2.0.0.27-fc5.i586

Natomiast jeżeli chodzi o twoje polecenia "Mentat " to też nic z tego nie wyszło:

]# rpm -Uvh yum skype-2.0.0.27-fc5.i586.rpm
błąd: otwarcie yum nie powiodło się: Nie ma takiego pliku ani katalogu
ostrzeżenie: skype-2.0.0.27-fc5.i586.rpm: Nagłówek V3 Podpis DSA: NOKEY, key ID d66b746e

/]# yum list qt4-x11
Loading "priorities" plugin
0 packages excluded due to repository priority protections
Available Packages
qt4-x11.i386                             4.3.3-1.fc7            updates         

Nie ogarniam tego, nie wiem jak to zrobić za cienki jestem tak by na to wyglądało.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Na początek spróbuj

yum localinstall skype-1.4.0.118-fc5.i586.rpm

a jak nie zadziała to

yum list qt4-x11

oraz

yum provides libQtGui.so.4

aby odnaleźć odpowiedni pakiet.

 

Nareszcie się udało. Sam jeszcze w to nie wierzę.

Dziękuję tobie "Mentat" to chyba dzieki tobie mi się udało.

To polecenie (yum localinstall skype-1.4.0.118-fc5.i586.rpm) zadane w katalogu w którym znajdowała się paczka Skypea nie przeszło do końca, ale dało początek. Bo za pomocą tego polecenia zainstalowałem ściągniętą paczkę (qt4-x11) , a następnie już za pomocą polecenia (rpm -Uvh skype-1.4.0.118-fc5.i586.rpm) udało się zainstalować Skype.

I muszę tu zaznaczyć że odwrotnie te polecenia w ogóle nie działały.

I jeszcze jedno to polecenie (yum update qt4-x11) nie działało.

Jeszcze raz dziękuję wszystkim którzy się zaangarzowali się aby mi pomóc.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wiem że może nie tego dotyczyło Twoje pytanie, ale dlaczego akurat skype, a nie otwarte aplikacje oparte o protokół SIP?

Różnica między skype a SIP jest taka jak między Windowsem a Linuksem - na SIPie są oparte nawet rozmowy przez Gadu-Gadu nagłos

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Wiem że może nie tego dotyczyło Twoje pytanie, ale dlaczego akurat skype, a nie otwarte aplikacje oparte o protokół SIP?

Różnica między skype a SIP jest taka jak między Windowsem a Linuksem - na SIPie są oparte nawet rozmowy przez Gadu-Gadu nagłos

 

Zapewne dlatego że większość ludzi używa skypa i o niczym innym nie słyszeli.

Od siebie dodam że jak się nie przeprowadza rozmów międzynarodowych to zabawa jest nieopłacalna, a poza tym nawet na linuksie skype pobiera od nas prywatne dane i wysyła do "centrali". Ktoś wykrył to zakładając odpowiednią politykę selinuksa na proces skypa. Po co im to nikt nie wie, ale najwidoczniej programiści skypa i linuksiarzy chcą mieć pod kontrolą, jakby im nie wystarczyła kasa, którą dostają za rozmowy.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

×