Jump to content
vitoo

Speedtouch/neostrada

Recommended Posts

Witam, stawiam pierwsze kroki w fedorze, na samym poczatku msuze powiedziec ze instalacja to bajka, oraz dziala karta ATI bezproblemowo. Pisze do was ponieważ napotkalem problem i nie moge sobie z nim poradzic. Od 2 godzin czytam o instalacji Neostrada (Speedtouch330) na fedorze, niestety najnowsze posty sa z 2008/2007 roku. Program "Net" juz nie jest kontynuowany, a terminal plata mi figle :)

 

Zglaszam sie do was z goraca prosba o pomoc w instalacji Neostrady na modemie Speedtouch330. Licze na was ;)

 

ps. W ktorym katalogu znajduje sie po zalogowaniu w terminalu na (_root'a_ → roota) ORT? ( etc/ ?)

 

 

Solved!

Opisze teraz krok po kroku jak mi sie udalo dzieki pomocy Pienia oraz thof'a. Jeszcze raz serdeczne dzieki!

 

Wersja orginalna:

http://linux-usb.sourceforge.net/SpeedTouc...dora/index.html

 

Zaczynamy.

1. Radze sciagnac wszystkie pliki ktore wypisze poniewaz wiem z autopsji ze przelaczanie sie miedzy systemami jest zmudne :)

Zatem sciagamy:

 

2. wchodzimy w terminal Programy>>Narzedzia Systemowe>>Terminal

 

Wpisujemy

su -
oraz haslo (nie widac zadnych gwiazdek kropek)

Nastepnie sprawdzamy jaka mamy wersje modemu

awk '/4061/ { print $5 }' /proc/bus/usb/devices

 

3. W zaleznosci jaka mamy wersje:

Version 0

Sciagamy speedmgmt.tar.gz

tar xzf speedmgmt.tar.gz &&
chmod +x firmware-extractor &&
./firmware-extractor mgmt/mgmt.o

 

Version 2

 

 

Dokoncze jutro :)

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Sposób opisany w temacie http://forum.fedora.pl/index.php?showtopic=9762 nadal działa, sprawdzałem. Przeczytaj sobie też ostatnią stronę tego tematu.

EDIT: po zalogowaniu się na konto roota (su -) znajdujesz się w jego folderze domowym, czyli /root, poza tym zawsze możesz to sprawdzić poleceniem pwd . Btw poczytaj http://wiki.fedora.pl/wiki/Poradnik zanim zadasz kolejne pytania.

Share this post


Link to post
Share on other sites

Thof, dziekuje za szybka odpowiedz. Tego sposobu co podales jeszcze nie wyprubowalem. Co do terminalu to wszystko ok, przestawiala mi sie klawiatura na inny jezyk i dlatego nie pyklo :)

 

Niestety sposob ktory jest zlinkowany w twoim poscie nie dziala. Wszystko zrobilem ok.

 

 

Share this post


Link to post
Share on other sites

Ja zawsze konfiguruję w/g opisu z tej strony: http://linux-usb.sourceforge.net/SpeedTouc...dora/index.html

Jednak gdy posiadasz wersję 64 bitową to będziesz potrzebował 64 bitowych wersji plików (a tam nie ma, trzeba poszukać na necie, albo do mnie się zgłosić): br2684ctl i libatm.so.1 (ten drugi jest akurat w pakiecie w repozytoriach fedory, szukaj czegoś z nazwą atm). Również firmware-extractor nie działa w fedorze 64 bitowej, ale bodajże ktoś znalazł obejście używając polecenia dd (tez chyba do znalezienia w necie, jeśli ktoś miał te dwie części firmware już wcześniej zainstalowane to można wykorzystać).

Share this post


Link to post
Share on other sites

Przez pomyłkę wkleiłem sposób dla sagema. W takim razie dla speedtoucha zrób wg tego http://forum.fedora.pl/index.php?showtopic=6475 do punktu 8. (tylko nie przeklejaj bezmyślnie). A dalej wg http://forum.fedora.pl/index.php?showtopic=9762 od momentu "Teraz trzeba wyedytowac plik /etc/ppp/chap-secrets - wygląda mniej więcej tak:" do końca (dowiązanie możesz pominąć). Aktualne adresy serwerów dns to 194.204.152.34

i 194.204.159.1.

Share this post


Link to post
Share on other sites
Przez pomyłkę wkleiłem sposób dla sagema. W takim razie dla speedtoucha zrób wg tego http://forum.fedora.pl/index.php?showtopic=6475 do punktu 8. (tylko nie przeklejaj bezmyślnie). A dalej wg http://forum.fedora.pl/index.php?showtopic=9762 od momentu "Teraz trzeba wyedytowac plik /etc/ppp/chap-secrets - wygląda mniej więcej tak:" do końca (dowiązanie możesz pominąć). Aktualne adresy serwerów dns to 194.204.152.34

i 194.204.159.1.

 

Zrobilem wedlug tego sposobu

 

http://akademia.linuksa.pl/pl/neostrada-linux/#speedtouchfc

 

I wyskoczyla mi w pewnym momencie gwiazdka z czyms takim

Podsumowanie:

 

SELinux is preventing the ppp daemon from inserting kernel modules.

 

Szczegółowy opis:

 

SELinux has denied the Point-to-Point Protocol daemon from inserting a kernel

module. If pppd is not setup to insert kernel modules, this probably signals a

intrusion attempt.

 

Zezwalanie na dostęp:

 

If you want ppp to be able to insert kernel modules you need to turn on the

pppd_can_insmod boolean: "setsebool -P pppd_can_insmod=1"

 

Polecenie naprawy:

 

setsebool -P pppd_can_insmod=1

 

Dodatkowe informacje:

 

Kontekst źródłowy unconfined_u:system_r:pppd_t:s0

Kontekst docelowy system_u:object_r:insmod_exec_t:s0

Obiekty docelowe /sbin/modprobe [ file ]

Źródło sh

Ścieżka źródłowa /bin/bash

Port <Nieznane>

Komputer localhost

Źródłowe pakiety RPM bash-4.0-6.fc11

Docelowe pakiety RPM module-init-tools-3.7-9.fc11

RPM polityki selinux-policy-3.6.12-39.fc11

SELinux jest włączony True

Typ polityki targeted

MLS jest włączone True

Tryb wymuszania Enforcing

Nazwa wtyczki pppd_can_insmod

Nazwa komputera localhost

Platforma Linux localhost 2.6.29.4-167.fc11.i586 #1 SMP Wed

May 27 17:14:37 EDT 2009 i686 i686

Licznik alarmów 122

Po raz pierwszy pon, 22 cze 2009, 21:03:20

Po raz ostatni pon, 22 cze 2009, 21:11:15

Lokalny identyfikator 53dfb6d2-4e7d-43f9-891a-e05440d8407e

Liczba wierszy

 

Surowe komunikaty audytu

 

node=localhost type=AVC msg=audit(1245697875.504:102): avc: denied { getattr } for pid=3306 comm="sh" path="/sbin/modprobe" dev=dm-0 ino=15968 scontext=unconfined_u:system_r:pppd_t:s0 tcontext=system_u:object_r:insmod_exec_t:s0 tclass=file

 

node=localhost type=SYSCALL msg=audit(1245697875.504:102): arch=40000003 syscall=195 success=no exit=-13 a0=91fb450 a1=bfdecfd0 a2=7c4ff4 a3=91fb450 items=0 ppid=3305 pid=3306 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="sh" exe="/bin/bash" subj=unconfined_u:system_r:pppd_t:s0 key=(null)

 

Mozesz mi wyslac swoje gg na privie?

 

 

 

Share this post


Link to post
Share on other sites

Przecież sam komunikat proponuje ci co masz zrobić. Wykonaj z poziomu roota następujące polecenie:

 

setsebool -P pppd_can_insmod=1

Share this post


Link to post
Share on other sites
Przecież sam komunikat proponuje ci co masz zrobić. Wykonaj z poziomu roota następujące polecenie:

 

setsebool -P pppd_can_insmod=1

 

wykonalem nic nie dalo :(

Share this post


Link to post
Share on other sites

Pisałem, że z poziomu roota. Najpierw na konsoli wpisz:

 

su -

 

Podajesz hasło roota.

A potem to wcześniejsze polecenie.

Share this post


Link to post
Share on other sites
Pisałem, że z poziomu roota. Najpierw na konsoli wpisz:

 

su -

 

Podajesz hasło roota.

A potem to wcześniejsze polecenie.

 

Caly czas korzystam z poziomu roota :)

 

@Thof zaraz sprobuje

 

 

@Edit

Brak mi juz sil....

 

Czy nikt nie znalazl innego sposobu niz z 2005 roku?...

Share this post


Link to post
Share on other sites
Sprecyzuj co Ci nie działa. Na jakim etapie utknąłeś? Jakieś komunikaty? Logi?

 

Probowalem robic 3 sposobami ktore "podobno" dzialaja. Po wpisaniu komendy na polaczenie nie polaczylo, nawet jak wylaczylem SElinux. Szukam teraz programu Net w wersji 0.4 (net_0.4.tar.bz2) ale kazdy zapodaje link do glownej strony ktora juz nie dziala, a mirrorow nigdzie nie ma. Moze ktos z was ma plik net_0.4.tar.bz2 i moze mi poddeslac.

Share this post


Link to post
Share on other sites
Probowalem robic 3 sposobami ktore "podobno" dzialaja. P

 

Bo za dużo kombinujesz. :-) Podałem Ci link gdzie jest bardzo prosto opisana konfiguracja. Sam używam Speedtoucha 330 skonfigurowanego w/g tej instrukcji i działa :-) Sprawdź czy masz pakiety:rp-pppoe, ppp i linux-atm-libs poleceniami:

rpm -qa|grep ppp; rpm -qa|grep atm

Jeśli nie masz to je zainstaluj poleceniem:

yum install ppp linux-atm-libs rp-pppoe

Share this post


Link to post
Share on other sites
Czy nikt nie znalazl innego sposobu niz z 2005 roku?...
Rozwiązanie wymyślono już dawno: router z wbudowanym modemem ADSL i po kłopocie. Co do samego opisu to jest bardzo dobry, a jak coś jest dobre to po co zmieniać.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×