Jump to content

Medion Ctx925 Tv Analog, Dvb-t, Dvb-s Uruchamia Się Po Restarcie


MGo
 Share

Recommended Posts

Karta jak w temacie w slocie Dual-PCI. Przy pierwszym starcie (z wyłączonego komputera) - nie działa. Robię restart - zaczyna działać:

Zjawisko jest powtarzalne.

Porównałem dmesg:

Time: 16:12:01  Date: 03/18/10				      |	Time: 16:17:10  Date: 03/18/10
saa7134[0]: subsystem: 16be:0003, board: Medion 7134 [card=12 |	saa7134[0]: subsystem: 00be:0003, board: Medion 7134 [card=12
ppdev: user-space parallel port driver			      |	saa7134[0]: i2c eeprom 00: 80 16 00 00 10 00 04 00 40 01 80 1
saa7134[0]: i2c eeprom 00: be 16 03 00 54 20 1c 00 43 43 a9 1 |	saa7134[0]: i2c eeprom 10: 00 7f 86 00 ab 00 a0 00 00 10 30 0
saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 7 |	saa7134[0]: i2c eeprom 20: 00 40 00 00 00 00 01 00 00 3c 00 1
saa7134[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 1 |	saa7134[0]: i2c eeprom 30: a2 58 78 18 02 8c 80 00 02 50 00 3
saa7134[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b |	saa7134[0]: i2c eeprom 40: 56 1c 00 02 06 00 01 01 00 00 00 0
saa7134[0]: i2c eeprom 40: ff 1d 00 c2 86 10 01 01 00 00 fd 7 |	saa7134[0]: i2c eeprom 50: d3 d4 b8 13 04 77 00 06 0c 00 00 0
saa7134[0]: i2c eeprom 50: ff ff ff ff ff ff 06 06 0f 00 0f 0 |	saa7134[0]: i2c eeprom 60: 20 d4 b8 12 00 c2 fd 80 bb 51 30 7
saa7134[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom 70: d6 5e 1a 7d 00 86 b9 5e 1b fa 00 8
saa7134[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom 80: e9 f0 00 8c b9 50 76 50 10 20 ab d
saa7134[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom 90: 02 d4 bc 12 00 d4 b8 14 13 83 fa f
saa7134[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom a0: e0 00 00 50 71 d4 b8 11 28 50 41 d
saa7134[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom b0: e0 51 10 d4 b8 14 13 83 fa ff fe 5
saa7134[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom c0: 00 50 b2 d4 b8 11 28 96 bc 8c c0 0
saa7134[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom d0: b8 11 28 67 d0 d4 bc 11 28 d4 b8 1
saa7134[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom e0: 1f 58 1a 8d e0 00 80 50 52 d4 b8 1
saa7134[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff f |	saa7134[0]: i2c eeprom f0: 00 50 40 d4 b8 12 04 81 fa 20 00 d
saa7134[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff f <
saa7134[0] Board has DVB-T				      |	saa7134[0] Cant determine tuner type 1000 from EEPROM
						      >	tuner 3-0043: chip found @ 0x86 (saa7134[0])
						      >	tda9887 3-0043: creating new instance
						      >	tda9887 3-0043: tda988[5/6/7] found
saa7134[1]: board init: gpio is 0			      |	saa7134[1]: board init: gpio is 510006

 

Działa wtedy, gdy dmesg jest jak ten w prawej kolumnie. Jak umożliwić start karty bez restartu?

 

/etc/modprobe.d/saa7134.conf:

alias char-major-81 videodev
alias char-major-81-0 saa7134
alias char-major-81-1 saa7134
options saa7134 radio_nr=0 card=12,93 tuner=63 gbuffers=4

Link to comment
Share on other sites

Może wystarczy przeładować moduł, czyli rmmod nazwa_modułu i modprobe nazwa_modułu .

Po przeładowaniu karta działa.

Ale po odpaleniu X-ów:

[[email protected] ~]# rmmod saa7134_alsa
ERROR: Module saa7134_alsa is in use

Trzeba ręcznie wyłączyć 2 urządzenia karty SAA7134 w preferencjach dźwięku - wtedy można przeładować. Potem włączyć ponownie.

Jak to zrobić automatycznie przy starcie? Do którego pliku wpisać polecenie przeładowania, aby moduł saa7134_alsa nie był zablokowany?

Do przeładowania są moduły saa7134, saa7134_dvb i saa7134_alsa.

 

EDIT

Stworzyłem plik /etc/init.d/saa7134

#!/bin/sh
#
#
#   saa7134 workaround
#
#   Linux chkconfig stuff:
#
#   chkconfig: 2345 25 10
#   description: saa7134 workaround.
# Linux
#
### BEGIN INIT INFO
# Provides: saa7134 workaround
# Required-Start: 
# Required-Stop: 
# Should-Start: 
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: saa7134 workaround
# Description: saa7134 workaround
### END INIT INFO


start () {
   /sbin/rmmod saa7134_alsa saa7134_dvb saa7134  2>&1 > /dev/null
   echo "Przeładowywanie SAA7134"
   RETVAL=$?
   /bin/sleep 1
   /sbin/modprobe saa7134  2>&1 > /dev/null
return $RETVAL
}


case $1 in
start)
	start
;;
stop)

;;
*)

echo $"Usage: $prog {start|stop}"
exit 2
esac

exit $RETVAL

... i już działa.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...