Skocz do zawartości
ruus

Brak Internetu Na Fedorze

Rekomendowane odpowiedzi

Witam, mam od kilku dni problem z moją Fedorą 21. Nie mogę nawiązać połączenia z internetem. Problem wygląda tak: jakiś czas temu zainstalowałem sobie Fedorę i obok windowsa. Na codzień korzystam z Fedory, ale kilka dni temu miałem jakieś problemy z internetem na mieszkaniu, raz był raz nie było więc zgłosiłem to dostawcy. Przyjechał serwisant, wszystko naprawił (najprawdopodobnej zresetował całe ustawienia routera) i tu zaczął się problem. Wraz z współlokatorami sprawdzaliśmy na laptopach czy wszystko działa i było ok. Wprawdzie mi na Fedorze najpierw nie odpalił internet, ale przełączyłem na windowsa i połączyło, tak jak i moim współlokatorom. Następnie przełączyłem się na Fedorę, bo głównie na tym systemie zależy mi na internecie. I internet był. Niestety tylko do momentu wyłączenia komputera. Gdy wyłączyłem od tego czasu nie mam już internetu na fedorze, natomiast na windowsie zarówno u mnie jak i u dwóch kolegów wszystko śmiga pięknie. Kablowo tego jeszcze nie sprawdzałem, jutro się za to zabiorę. Nie wiem co mam podać, żeby pomóc zdiagnozować problem więc proszę o komentarze.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Łączysz się kablem czy przez wi-fi?

 

Jeżeli bezprzewodowo, to sprawdź, czy na kablu chodzi. I wtedy pogrzeb w ustawieniach wi-fi. Po zresetowaniu routera mogło coś pofiksować, może wystarczy jeszcze raz skonfigurować połączenie?

 

Mogło być też tak, że po update systemu wyłączyło Ci kartę wi - fi. Mało prawdopodobne, ale sprawdź to. U mnie też tak przez moment było, że na kablu hulał, a bez juz nie chciał. Skonfigurowałam połączenie na nowo i tyle.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nie możesz nawiązać połączenia z internetem, ale z siecią możesz?

1. sprawdź DNSy, zobacz co masz wpisanego w pliku resolv.conf

$ cat /etc/resolv.conf

 

Tam powinnien znajdować się np taki oto wpis:

nameserver 8.8.8.8
 
2. Czy pingi działają?
Zobacz ustawienia i adres kolegi na windowsie i spinguj ten adres. Jeżeli na tym samym komputerze z Windowsem działa internet to wprowadź identyczne ustawienia.
 
3. Sprawdź polecenie u siebie "ifconfig" i zobacz jakie znajdziesz tam informacje  (btw w najnowszym CentOSie tego polecenia nie ma w standardzie, trzeba doinstalować paczki:)

 

4. Sprawdź statusy

service network status

service NetworkManager status

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wczoraj sprawdzałem, nie działa zarówno kablowo jak i przez wifi, na windowsie na tym samym komputerze działa i tak i tak. Ustawienia są takie same.

1. sprawdź DNSy, zobacz co masz wpisanego w pliku resolv.conf

# Generated by NetworkManager
search local
# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:
#
# DNS1=xxx.xxx.xxx.xxx
# DNS2=xxx.xxx.xxx.xxx
# DOMAIN=lab.foo.com bar.foo.com

3. ifconfig:

enp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 20:1a:06:fb:e6:38  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 8036  bytes 648258 (633.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8036  bytes 648258 (633.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 96:30:bc:4b:f9:26  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 48:5a:b6:e5:96:99  txqueuelen 1000  (Ethernet)
        RX packets 8  bytes 764 (764.0 
        RX errors 0  dropped 0  overruns 0  frame 1473
        TX packets 14  bytes 2352 (2.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  

4. Sprawdź statusy

service network status
Skonfigurowane urządzenia:
lo (tu wymienione wszystkie moje sieci zarowno te co dzialają jak I te co nie działają)
Obecnie aktywne urządzenia:
lo enp1s0 wlp2s0 virbr0
service NetworkManager status
Redirecting to /bin/systemctl status  -l NetworkManager.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since czw 2015-03-26 22:14:01 CET; 18min ago
 Main PID: 830 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─830 /usr/sbin/NetworkManager --no-daemon

mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  (wlp2s0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  NetworkManager state is now CONNECTED_LOCAL
mar 26 22:29:29 fedora.local NetworkManager[830]: <warn>  Activation (wlp2s0) failed for connection '(nazwa sieci z którą nie mogę się połączyć'
mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  Activation (wlp2s0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  (wlp2s0): device state change: failed -> disconnected (reason 'none') [120 30 0]
mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  (wlp2s0): deactivating device (reason 'none') [0]
mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  (wlp2s0): canceled DHCP transaction
mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  Connectivity check for uri 'https://fedoraproject.org/static/hotspot.txt' failed with 'Błąd podczas rozwiązywania "fedoraproject.org": Ta nazwa lub usługa jest nieznana'.
mar 26 22:29:29 fedora.local NetworkManager[830]: <warn>  Connection disconnected (reason -3)
mar 26 22:29:29 fedora.local NetworkManager[830]: <info>  (wlp2s0): supplicant interface state: completed -> disconnected

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Po ostatniej aktualizacji systemu zniknęła mi ikonka połączenia bezprzewodowego w Ustawieniach. W internecie wyczytałem, że potrzebuję pakietu: kmod-ndiswrapper. Natomiast próba jego instalacji:

sudo yum install kmod-ndiswrapper

Po wcześniejszym dodaniu repo:

su -c 'rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm'

su -c 'rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm'

Kończy się takimi komunikatami w terminalu:

Wczytane wtyczki: langpacks
Rozwiązywanie zależności
--> Wykonywanie sprawdzania transakcji
---> Pakiet kmod-ndiswrapper.x86_64 0:1.59-7.fc21.15 zostanie zainstalowany
--> Przetwarzanie zależności: kmod-ndiswrapper-3.19.2-201.fc21.x86_64 >= 1.59-7.fc21.15 dla pakietu: kmod-ndiswrapper-1.59-7.fc21.15.x86_64
--> Wykonywanie sprawdzania transakcji
---> Pakiet kmod-ndiswrapper-3.19.2-201.fc21.x86_64.x86_64 0:1.59-7.fc21.15 zostanie zainstalowany
--> Przetwarzanie zależności: kernel-uname-r = 3.19.2-201.fc21.x86_64 dla pakietu: kmod-ndiswrapper-3.19.2-201.fc21.x86_64-1.59-7.fc21.15.x86_64
--> Przetwarzanie zależności: ndiswrapper-kmod-common >= 1.59 dla pakietu: kmod-ndiswrapper-3.19.2-201.fc21.x86_64-1.59-7.fc21.15.x86_64
--> Wykonywanie sprawdzania transakcji
---> Pakiet kmod-ndiswrapper-3.19.2-201.fc21.x86_64.x86_64 0:1.59-7.fc21.15 zostanie zainstalowany
--> Przetwarzanie zależności: kernel-uname-r = 3.19.2-201.fc21.x86_64 dla pakietu: kmod-ndiswrapper-3.19.2-201.fc21.x86_64-1.59-7.fc21.15.x86_64
---> Pakiet ndiswrapper.x86_64 0:1.59-1.fc20 zostanie zainstalowany
--> Ukończono rozwiązywanie zależności
Błąd: Pakiet: kmod-ndiswrapper-3.19.2-201.fc21.x86_64-1.59-7.fc21.15.x86_64 (rpmfusion-free-updates)
          Wymaga: kernel-uname-r = 3.19.2-201.fc21.x86_64
          Zainstalowano: kernel-core-3.17.4-301.fc21.x86_64 (@koji-override-0/$releasever)
              kernel-uname-r = 3.17.4-301.fc21.x86_64
          Zainstalowano: kernel-core-3.19.3-200.fc21.x86_64 (@updates)
              kernel-uname-r = 3.19.3-200.fc21.x86_64
          Dostępne: kernel-debug-core-3.17.4-301.fc21.x86_64 (fedora)
              kernel-uname-r = 3.17.4-301.fc21.x86_64+debug
          Dostępne: kernel-debug-core-3.19.3-200.fc21.x86_64 (updates)
              kernel-uname-r = 3.19.3-200.fc21.x86_64+debug
 Można spróbować użyć --skip-broken, aby obejść problem
 Można spróbować wykonać polecenie: rpm -Va --nofiles --nodigest

Próbowałem znaleźć rozwiązanie w internecie, ale chyba jestem na to za głupi, bo nie wiem co zrobić aby działało :)

 

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×