Jump to content
Tellmewhen

Instalacja MongoDB

Recommended Posts

Witam, od kilku dni przesiadłem się z windowsa na Fedora ( tak jest to mój pierwszy raz :)  ), a już od początku mam pod górkę .... Potrzebuej zainstalować MongooDB ale niestety idzie to jak krew z nosa znalazłem prezentacje pod ubuntu  ale tutaj te komendy nie działają , czy ktoś jest w stanie mi pomóc ? wkleje tutaj komendy które potrzebuje :P. ps uzywam Fedora 29

1. sudo apt -key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 9DA31620334BD75D9DCB49F368818C7 2E52529D4                << tego nie moge znaleść

2.echo "deb [ arch=amd64 ] https://repo.mongodb.org/apt/ubuntu bionic/mongodb -org/4.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb -org - 4.0.list          <<< jak się do tego odwołac ?

3.sudo apt -get update    || sudo dnf update  ;]

4.sudo apt -get install mongodb -org   

5.sudo systemctl enable mongodb

Wiem może wydawać sie to głupie alee ... nie ma głupich pytań są tylko głupie odpowiedzi :p

Share this post


Link to post
Share on other sites

Do poczytania:

https://fedoraproject.org/wiki/User_Guide_-_Managing_Software

https://wiki.archlinux.org/index.php/Pacman/Rosetta

 

W skrócie:

1. Aktualizacja wszystkich pakietów do najnowszych wersji - jako root:

dnf distro-sync

2. Wyszukiwanie pakietów:

dnf search all mongo

3. Instalacja pakietów:

dnf install nazwa

4. Usuwanie pakietów:

dnf remove nazwa

W linuksie oprogramowanie instalujemy z repozytorium - porzuć przyzwyczajenia z Windows...

 

Share this post


Link to post
Share on other sites

Instalujesz serwer mongodb poleceniem

dnf install mongodb-server

Następnie uruchamiasz go poleceniem

systemctl start mongod.service

Sprawdzasz czy usługa wystartowała pomyślnie poleceniem

systemctl status mongod.service

Jeżeli wszystko jest ok powinieneś mieć wyświetlony na zielono status

Active: active (running)

Jeżeli chcesz by usługa startowała razem z systemem musisz wykonać polecenie

systemctl enable mongod.service

Domyślnie mongodb nasłuchuje tylko na localhost, jeżeli chcesz aby nasłuchiwała innym adresie musisz to zmienić w konfiguracji oraz dodatkowa odblokować port na firewallu.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...