Jump to content
Sign in to follow this  
daver

"klucz Publiczny Nie Jest Zainstalowany"

Recommended Posts

Witam ponownie. Pojawil sie kolejny problem, wlasciwie nie wiem skad.

Przy probie instalacji niektorych paczek pzy pomocy (_yum'a_ → yuma) ORT, np. podczas update otrzymuję taki kompunikat:

Klucz publiczny dla rpmfusion-nonfree-release-11-1.noarch.rpm nie jest zainstalowany

Kiedy probuje zainstalowac jakis inny program, czy kodek, pojawia sie podobny komunikat, ale najczesciej brakuje innego klucza. Probowalem juz czyscic (_yum'a_ → yuma) ORT, szukalem tez rozwiazania, ale jak dotad nie poradzilem sonie z tym problemem. Proszę o pomoc.

Share this post


Link to post
Share on other sites

Fedora 11? Czy to nie jest jakiś bug związany z importem kluczy? Theriel coś dzisiaj wspominał chyba o tym właśnie → http://forum.fedora.pl/index.php?s=&sh...st&p=124367

 

Zasadniczo jeśli klucze są standardowo w /etc/pki/rpm-gpg, to powinno pomóc polecenie rpm --import, ale tutaj → http://forums.fedoraforum.org/showpost.php...amp;postcount=3 widać, że jakoś nie bardzo to działa.

 

Masz dwa wyjścia:

1.bezpieczne - wstrzymać się z aktualizacjami na jakiś czas (pewnie do wydania stabilnej wersji F11 jeśli to o tej wersji mowa)

2.mniej bezpieczne - stosować opcję --nogpgcheck

 

 

Share this post


Link to post
Share on other sites

Tak, Fedora 11,

Chwilę przed Twoim postem odkryłem możliwość bezproblemowej aktualizacji z parametrem --nogpgcheck. Edytowałem nieco yum.conf zmieniając gpgcheck na 0, ale i tak bez stosowania parametru --nogpgcheck w składni polecenia nie daj się obejść. Pisałeś o ryzyku, jakie niesie za sobą stosowanie --nogpgcheck. Jakie ono jest ?

Dziękuję bardzo za pomoc.

Share this post


Link to post
Share on other sites

Niebezpieczeństwo jest takie, że możesz pobrać paczkę niepodpisaną przez twórców Fedory, która w istocie będzie zawierała specjalnie spreparowany kod umożliwiający przejęcie kontroli nad Twoim komputerem (albo jeszcze coś innego). Oczywiście zrobienie i dodanie takiej paczki nie jest proste, aczkolwiek jakiś czas temu, o ile mnie pamięć nie myli, udało się takie coś zrobić.

 

Na Twoim miejscy przywróciłbym standardowe ustawienia parametru gpgcheck=1 i w razie konieczności korzystał z opcji --nogpgcheck

Share this post


Link to post
Share on other sites

To jest właśnie ten błąd, o którym pisałem. Po pierwsze: przywróć ustawienia dla gpgcheck=1.

 

Jeśli zainstalowałeś tę paczkę - spokojnie, pewnie repozytorium przygotowują pod oficjalne wydanie i trochę zamieszania się robi, więc powinno być OK. Ja ją przeforsowałem nogpgcheck.

 

Musisz liczyć się z tym, że póki co repozytoria są trochę "pokręcone" - u mnie np: pojawiają się problemy z dependencies w rpmfusion-nonfree-updates. Minie kilka dni i będzie OK.

Share this post


Link to post
Share on other sites
Edytowałem nieco yum.conf zmieniając gpgcheck na 0
Każdy plik konfiguracyjny repozytorium ma własne ustawienia sprawdzania podpisu. Musiałbyś we wszystkich plikach *.repo w katalogu /etc/yum.repos.d w każdej sekcji gdzie masz enabled=1 ustawić gpgcheck=0 - chyba za dużo z tym roboty. Szybciej i prościej --nogpgcheck dodać za każdym razem.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...