Jump to content
Sign in to follow this  
SeeM

Libre Office 6.4.x na Fedorze 31

Recommended Posts

Kompiluje się Libre Office z Rawhide na Fedorze 31. Komputer myśli. :) Pierwsze podejście się nie udało, ponieważ zabrakło miejsca na dysku. Powiększyłem partycję, ustawiłem 8xCPU i 16 giga ramu. Kiedy skończy, wystawię wam repozytorium. Nawet nie ma dużo zależności. Wiem, że jest Flatpak, ale dla mnie nie ma to jak binarka z RPMów.

 

lo.jpg

Share this post


Link to post
Share on other sites
1 godzinę temu, sunrise napisał:

Chyba czas na zakup UPSa.

To się u mnie zdarza raz na kilka miesięcy. ciekawe, że komputer stacjonarny się nie wyłączył, ale serwer taki delikatny.

Niestety:

błąd: Odnaleziono zainstalowane (ale niespakietowane) pliki:
   /usr/lib64/libreoffice/program/__pycache__/access2base.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/access2base.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/mailmerge.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/mailmerge.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/msgbox.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/msgbox.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/pythonloader.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/pythonloader.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/pythonscript.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/pythonscript.cpython-37.pyc


Błędy budowania pakietu RPM:
    bezwzględne dowiązanie symboliczne: /usr/bin/soffice → /usr/lib64/libreoffice/program/soffice
    bezwzględne dowiązanie symboliczne: /usr/lib64/libreoffice/share/autocorr → /usr/share/autocorr
    Odnaleziono zainstalowane (ale niespakietowane) pliki:
   /usr/lib64/libreoffice/program/__pycache__/access2base.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/access2base.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/mailmerge.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/mailmerge.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/msgbox.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/msgbox.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/pythonloader.cpython-37.opt-1.pyc
   /usr/lib64/libreoffice/program/__pycache__/pythonloader.cpython-37.pyc
   /usr/lib64/libreoffice/program/__pycache__/pythonscript.cpython-37.opt-1.pyc

Na Fedorze 32 jest już Python 3.8 i te pliki pewnie mają końcówkę *cpython-38.opt-1.pyc. Trzeba będzie poprawić SPECa i puścić kompilację jeszcze raz, albo ewentualnie wyrzucić z części %prep usuwaine tymczasowych katalogów. No nic, w każdym razie zrobi się jutro.

EDIT: SPEC poprawiony, ale nie chce mi się dzisiaj czekać do północy. Jutro się zrobi.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...