Jump to content
kaktus250

Błędy Podczas Instalacji Yumem Phpmyadmin W Fc6

Recommended Posts

Piszę yum install phpmyadmin i dostaję

[[email protected] var]# yum install phpmyadmin

Loading "installonlyn" plugin

Setting up Install Process

Setting up repositories

http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (111, 'Po\xc5\x82\xc4\x85czenie odrzucone')>

Trying other mirror.

Error: Cannot open/read repomd.xml file for repository: core

 

Myślę że chodzi o problem z repozytoriami:

W /etc/yum.repos.d mam:

adobe-linux-i386.repo

fedora-core.repo

fedora-development.repo

fedora-extras-development.repo

fedora-extras.repo

fedora-updates-testing.repo

fedora-updates.repo

 

---------------------------------

W fedora-core.repo mam:

 

name=Fedora Core $releasever - $basearch

baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/os/

#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=core-$releasever&arch=$basearch

enabled=1

gpgcheck=1

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

 

[core-debuginfo]

name=Fedora Core $releasever - $basearch - Debug

baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/debug/

#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=core-debug-$releasever&arch=$basearch

enabled=0

gpgcheck=1

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

 

[core-source]

name=Fedora Core $releasever - Source

baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/source/SRPMS/

#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=core-source-$releasever&arch=$basearch

enabled=0

gpgcheck=1

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

 

Zamiana haszów z mirror na baseurl nic nie daje.

 

JAk kliknę Dodaj/usuń oprogramowanie to dostaję błąd:

Cannot open/read repomd.xml file for repository: core

 

 

Co zrobić by repozytoria działały ? Jak decydować, które mają się włączać ?

Czy to jest winą że yum nie działa ?

 

pozdrawiam forumowiczów i proszę o pomoc. Już kombinowałem yum clear yum update, błędy błędy.

Share this post


Link to post
Share on other sites

Jeśli nie zrobiłeś literówki i to faktycznie FC6 to niczego już nie zainstalujesz. To stara, nie wspierana wersja.

Któryś z forumowiczów wkleił tu kiedyś linka do nieoficjalnego repozytorium, poszukaj w googlach a znajdziesz.

Drugie wyjście to przeinstalowanie systemu do najnowszej wersji.

Share this post


Link to post
Share on other sites

Jeśli nie zrobiłeś literówki i to faktycznie FC6 to niczego już nie zainstalujesz. To stara, nie wspierana wersja.

Któryś z forumowiczów wkleił tu kiedyś linka do nieoficjalnego repozytorium, poszukaj w googlach a znajdziesz.

Drugie wyjście to przeinstalowanie systemu do najnowszej wersji.

To FC 6 - nie ma pomyłki. Mam tu kilka rzeczy działających i teraz na nowo - sporo roboty.

Jak znajdę to nieoficjalne repozytorium to wystarczy że wrzucę do /etc/yum.repos.d ? czy jeszcze coś ?

Share this post


Link to post
Share on other sites
Jak znajdę to nieoficjalne repozytorium to wystarczy że wrzucę do /etc/yum.repos.d ? czy jeszcze coś ?
Wystarczy, ale dlaczego chcesz nieoficjalne ;) Są archiwalne repozytoria. Nowości na FC6 się nie spodziewaj, ale phpmyadmin pewnie jakieś starsze się znajdzie → http://mirrors.fedoraproject.org/publiclist/

Share this post


Link to post
Share on other sites

To FC 6 - nie ma pomyłki. Mam tu kilka rzeczy działających i teraz na nowo - sporo roboty.

 

Fakt, te wszystkie rootkity i backdoory jakie Ci powrzucali przestaną działać po aktualizacji :)

Share this post


Link to post
Share on other sites

Skorzystałem z rady sokara620, nic z repozytorium nie zainstalowałem, ale teraz mogę uruchomić Dodaj/Usuń programy a to już dużo.

Jest inny problem:

Po zainstalowaniu PhpMyAdmin mogę się zalogować, ale jest komunikat:

"

Rozszerzenie PHP o nazwie mbstring nie zostało znalezione, a wygląda na to, że używasz wielobajtowego zestawu znaków. Bez rozszerzenia mbstring phpMyAdmin nie ma możliwości poprawnego rozbijania napisów, co może skutkować niespodziewanymi rezultatami.

"

Szukałem w Interncie, ale mój plik php.ini wygląda inaczej niż opisywane, tzn mam takie wpisy dotyczące mbstring:

"

[mbstring]

; language for internal character representation.

;mbstring.language = Japanese

mbstring.language = neutral

 

; internal/script encoding.

; Some encoding cannot work as internal encoding.

; (e.g. SJIS, BIG5, ISO-2022-*)

;mbstring.internal_encoding = EUC-JP

mbstring.internal_encoding = ISO-2022

 

; http input encoding.

;mbstring.http_input = auto

mbstring.http_input = auto

 

; http output encoding. mb_output_handler must be

; registered as output buffer to function

;mbstring.http_output = SJIS

mbstring.http_output = SJIS

 

; enable automatic encoding translation according to

; mbstring.internal_encoding setting. Input chars are

; converted to internal encoding by setting this to On.

; Note: Do _not_ use automatic encoding translation for

; portable libs/applications.

;mbstring.encoding_translation = Off

 

; automatic encoding detection order.

; auto means

;mbstring.detect_order = auto

mbstring.detect_order = auto

 

; substitute_character used when character cannot be converted

; one from another

;mbstring.substitute_character = none;

mbstring.substitute_character = none;

 

"

 

 

Domyślnie wszystko było zakomentowane, dopisałem linie które są bez komentarza;

Jak się pozbyć błędu dot mbstring ?

Share this post


Link to post
Share on other sites

Dzięki,

pobrałem php-mbstring-5.1.6-3.i386.rpm

i zainstalowałem:

rpm -ivh php-mbstring-5.1.6-3.i386.rpm

 

restart serwera httpd i mysqld

i działa bez błędu.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...