Moterrola

Touchpad odmawia współpracy po dyskusji z Fedorą

5 postów w tym temacie

Witam serdecznie wszystkich użytkowników. 
Odkąd zainstalowałem Windowsa 7 na swoim laptopie (Acer E5-571), nieustannie mam problemy z touchpadem. 
Posiadam zainstalowany system Windows 7 Enterprise x64 i równolegle najnowszą wersję Fedory. Problem polega na tym, że pod Windowsem touchpad działa doskonale, pod Linuxem też, ale potem pod Windowsem już przestaje. Wygląda to tak:
-Bootuję Windowsa - touchpad działa
-Restartuję w Fedorę - touchpad wciąż działa
-Restartuję w Windowsa - kursor nie reaguje na nic, a w Menedżerze Urządzeń pojawia się błąd o treści: "Nie można uruchomić urządzenia (Kod 10)."

Jedynym remedium okazuje się reflash biosu. Kiedy zainstaluję najnowszą wersję biosu pod Windowsem, to po wprowadzeniu ustawień touchpad ożywa. Aż do momentu, kiedy znów nie odpalę Linuxa. Co próbowałem zrobić do tej pory:
-Wcześniejsza moja konfiguracja to były oba systemy zainstalowane w trybie legacy na partycjach MBR na dysku talerzowym, domyślnym dla tego laptopa. Problem występował.
-Dorwałem dysk SSD Intela 160GB i zainstalowałem na nim oba systemy pod UEFI (gdzieś wyczytałem, że to powinno pomóc) na partycjach GPT. Problem wciąż nie ustępuje.
-Próbowałem zmieniać w biosie ustawienia Secure Bootu - zarówno z wyłączonym, jak i z włączonym (i z jednym i drugim systemem dodanym do zaufanych) problem wciąż występuje.
-Zainstalowałem najnowsze sterowniki pod Windowsa jakie udało mi się znaleźć, spoza supportu Acera. Nadal nic się nie zmieniło.

Nie bardzo mam już pomysł, co z tym zrobić, stąd piszę na forum. Ktoś ma jakieś pomysły?

Touchpad to Elan gadający przez PS/2, identyfikator w windowsowym menedżerze urządzeń to ACPI\ETD0502.
Pytajcie śmiało o wszelkie szczegóły hardwareowe, których znajomości potrzebujecie. 

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Pewnie już tego próbowałeś, ale i tak zapytam: laptop przypuszczalnie ma jakiś dedykowany klawisz do włączania i wyłączania dotyku. Spróbuj wyłączyć go na Linuksie i uruchomić Windows. Jeżeli nie ma takiego klawisza, możesz użyć xinput, tak jak wyjaśniono tutaj - https://askubuntu.com/questions/65951/how-to-disable-the-touchpad

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Posiadam taki klawisz i rzeczywiście, wcześniej tego nie próbowałem. Mimo to - nie pomogło.

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ja może nie pomogę ale dodam swoje 3 grosze ; na lapku acer 7540G problem jest podobny ;

na windows touchpad działa prawidłowo  , a na wszystkich dystrybucjach linuksa , wszystkich ją drach i różnych puilpitach -

mogę go wyłączyć tylko 1 raz . Potem już klawisz włączania/wyłączania gładzika nic nie daje .

Tylko polecenia w konsoli ; RMMOD PSMOUSE  a potem MODPROBE PSMOUSE - pomagają .

Spróbuj Moterrola tych 2 komend konsoli .

O dziwo ; u mnie ten problem nie występuje na systemie *BSD ....

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nie do końca o to chodzi - pod linuxem działa przez cały czas. Mogę sobie zbootować  z powrotem do windowsa, potem z prowrotem na linuxa i touchpad pod linuxem działa perfekcyjnie. To właśnie na Windowsie przestaje działać po tym jak odpalę Linuxa.

Kiedy robię rmmod psmouse, to dostaję jedynie błąd, że psmouse jest "built-in" :/

0

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz