Jump to content
mariusz90

[CentOS 7.6]Problem z kartą graficzną Radeon HD6450

Recommended Posts

Cześć

Mam następujący problem z kartą graficzną Radeon HD 6450:

06/04/2019 13:28:22 localhost kernel [drm:r600_ring_test [radeon]] *ERROR* radeon: ring 0 test failed (scratch(0x8504)=0xCAFEDEAD)
06/04/2019 13:28:22	localhost kernel radeon 0000:04:00.0: disabling GPU acceleration

Mam zainstalowaną wersję CentOS

centos-release-7-6.1810.2.el7.centos.x86_64

Wersję kernela:

kernel-3.10.0-957.el7.x86_64
kernel-3.10.0-957.10.1.el7.x86_64

Oprócz tego błędu mam na ekranie pojawiające się paski pionowe, które nie znikają.

Jeżeli potrzebujecie jeszcze jakiś informacji to piszcie jak możecie jakie polecenia w konsoli mam wykonać. Błąd ten sam pojawia się też u mnie na innych dystrybucjach linuksowych.

Gdy chce zainstalować sterowniki z oficjalnej strony występuję następujący błąd:

./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run
Created directory fglrx-install.jEtVkv
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-15.201.1151......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================

error: Detected X Server version 'XServer 1.20.1_64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib:XServer 1.20.1_64a:none:3.10.0-957.10.1.el7.x86_64:)
Installation will not proceed.

Removing temporary directory: fglrx-install.jEtVkv

Czy może mi ktoś napisać. Jak mogę rozwiązać ten problem

Share this post


Link to post
Share on other sites

Nie wiem czy coś poradzisz. Po pobieżnym przejrzeniu internetu wychodzi że ten błąd poprawiono/znikł dopiero w kernelu 4.17, więc musisz wybrać jakąś bardziej aktualną dystrybucję.

Share this post


Link to post
Share on other sites
1 godzinę temu, sunrise napisał:

Nie wiem czy coś poradzisz. Po pobieżnym przejrzeniu internetu wychodzi że ten błąd poprawiono/znikł dopiero w kernelu 4.17, więc musisz wybrać jakąś bardziej aktualną dystrybucję.

Cześć. Ten sam błąd występuje w opensuse wersji rozwojowej oraz w Fedorze 29. 

Share this post


Link to post
Share on other sites

Nadal nic. Po wpisaniu radeon.modeset=0 . Nadal obraz pozostawia dużo do życzenia. I nie można komfortowo pracować.

Share this post


Link to post
Share on other sites

Też o tym myślałem. Spróbuję może coś pomoże. Podczas instalacji pojawia się błąd:

Downloading packages:                                                                                                                                                                                                                        
Running transaction check                                                                                                                                                                                                                    
Running transaction test                                                                                                                                                                                                                     
Transaction test succeeded                                                                                                                                                                                                                   
Running transaction
error: Detected X Server version 'XServer 1.20.1_64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10
błąd: Skrypt %pre(fglrx64_p_i_c-15.201.1151-1.x86_64) się nie powiódł, stan wyjścia 1
Error in PREIN scriptlet in rpm package fglrx64_p_i_c-15.201.1151-1.x86_64
  Sprawdzanie: fglrx64_p_i_c-15.201.1151-1.x86_64                                                                                                                                                                          1/1 

Nie powiodło się:
  fglrx64_p_i_c.x86_64 0:15.201.1151-1  

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×