Jump to content
root4u

Problem Z Serwerem Ftp I Http Na Fedora

Recommended Posts

Mam problem ponieważ uruchomiłem serwer www i ftp ale na obydwa nie mogę sie zalogować z innego komputera w sieci lokalnej. Kiedy wpisze w przeglądarce (na tym samym komputerze co jest apache) 192.168.1.100 strona otwiera się normalnie, kiedy wpisze ten sam adres w laptopie strona nie otwiera się. To samo jest z vsftpd kiedy w fille zilla (na tym samym komputerze co jest serwer) wpisze adres 192.168.1.100 login i hasło to wszystko działa bez problemu mogę wgrywać kasować itp. Kiedy jednak spróbuje z laptopa to pisze connented ale zatrzymuje się na

Connected to 192.168.1.100

Hostname: 192.168.1.100

username=login

startdir=

 

W logach routera (TP-Link tl-wr1043n) nic nie znajduje żeby blokował, ustawiłem virtual server na ftp i http nic nie pomogło

 

...
151    Sep 18 13:18:30    DHCP     NOTICE     DHCPC:GET ip:59e48bb6 mask:ffffe000 gateway:59e48001 dns1:d9ace0a0 dns2:59e40615
152    Sep 18 13:18:30    DHCP     NOTICE     Dynamic IP(DHCP Client) obtained an IP successfully
153    Sep 18 13:58:26    DHCP     NOTICE     DHCPS:Recv REQUEST from 1C:4B:D6:A7:89:7E
154    Sep 18 13:58:26    DHCP     NOTICE     DHCPS:Send ACK to 192.168.1.101
155    Sep 18 14:18:29    DHCP     NOTICE     DHCPC Send REQUEST to server c0a820e4 with request ip 59e48bb6
156    Sep 18 14:18:30    DHCP     NOTICE     DHCPC Recv ACK from server c0a820e4 with ip 59e48bb6 lease time 7200
157    Sep 18 14:18:30    DHCP     NOTICE     DHCPC:GET ip:59e48bb6 mask:ffffe000 gateway:59e48001 dns1:d9ace0a0 dns2:59e40615
158    Sep 18 14:18:30    DHCP     NOTICE     Dynamic IP(DHCP Client) obtained an IP successfully
159    Sep 18 14:21:51    DHCP     NOTICE     DHCPS:Recv REQUEST from 00:19:DB:B7:0E:8B
160    Sep 18 14:21:51    DHCP     NOTICE     DHCPS:Send ACK to 192.168.1.100
161    Sep 18 14:45:41    DHCP     NOTICE     DHCPS:Recv REQUEST from 00:19:DB:B7:0E:8B
162    Sep 18 14:45:41    DHCP     NOTICE     DHCPS:Send ACK to 192.168.1.100
163    Sep 18 14:58:24    DHCP     NOTICE     DHCPS:Recv REQUEST from 00:19:DB:B7:0E:8B
164    Sep 18 14:58:24    DHCP     NOTICE     DHCPS:Send ACK to 192.168.1.100
165    Sep 18 14:58:26    DHCP     NOTICE     DHCPS:Recv REQUEST from 1C:4B:D6:A7:89:7E
166    Sep 18 14:58:26    DHCP     NOTICE     DHCPS:Send ACK to 192.168.1.101

 

PS jak stawiam serwer na win (192.168.1.100) za pomoca hfs lub liteftp wszystko smiga jak trzeba. Wina musi leżeć po stronie Fedory.

 

Próbowałem dodać w etc/sysconfig/iptables

# Firewall configuration written by system-config-firewall

# Manual customization of this file is not recommended.

*filter

:INPUT ACCEPT [0:0]

:FORWARD ACCEPT [0:0]

:OUTPUT ACCEPT [0:0]

-A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

-A INPUT -p icmp -j ACCEPT

-A INPUT -i lo -j ACCEPT

-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT

-A INPUT -j REJECT --reject-with icmp-host-prohibited

-A FORWARD -j REJECT --reject-with icmp-host-prohibited

COMMIT

iptables -A INPUT -p tcp --dport 80 -j ACCEPT //apache

iptables -A INPUT -p tcp --dport 443 -j ACCEPT //apache ssl

-A INPUT -i eth0 -p tcp -m tcp --dport 20 -j ACCEPT

-A INPUT -i eth0 -p tcp -m tcp --dport 21 -j ACCEPT

-A INPUT -i eth0 -p udp -m udp --dport 20 -j ACCEPT

-A INPUT -i eth0 -p udp -m udp --dport 21 -j ACCEPT

 

Nic nie pomogło.

Share this post


Link to post
Share on other sites

Hello_world, zrestartowałem serwer i nie podziałało.

http://wklejto.pl/77481 - httpd.conf

 

[root@localhost Damian]# netstat -aptn

Active Internet connections (servers and established)

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name

tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1360/sshd

tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 1170/cupsd

tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 1517/sendmail: acce

tcp 0 0 0.0.0.0:49184 0.0.0.0:* LISTEN 1123/rpc.statd

tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 1486/mysqld

tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1064/rpcbind

tcp 0 0 :::22 :::* LISTEN 1360/sshd

tcp 0 0 ::1:631 :::* LISTEN 1170/cupsd

tcp 0 0 :::58798 :::* LISTEN 1123/rpc.statd

tcp 0 0 :::111 :::* LISTEN 1064/rpcbind

tcp 0 0 :::80 :::* LISTEN 1544/httpd

 

Share this post


Link to post
Share on other sites
Próbowałem dodać w etc/sysconfig/iptables

To jak probowałeś to pokaż jeszcze co ci pokazuje :

iptables -L

 

tcp 0 0 :::80 :::* LISTEN 1544/httpd

Ten wpis mówi o ipv6 jak się nie mylę

Share this post


Link to post
Share on other sites

[root@localhost Damian]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED 
ACCEPT     icmp --  anywhere             anywhere            
ACCEPT     all  --  anywhere             anywhere            
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ssh 
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited 

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited 

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

 

ip6 raczej to nie jest ponieważ po zmianie configa httpd nasłuchuje na 192.168.1.100:80 (w poprzednim poście pierw sprawdziłem netstat wkleiłem log potem dopiero zmieniłem configa) netstat po configu http://wklejto.pl/77573

 

Share this post


Link to post
Share on other sites

A mógł byś dać linka albo wyjaśnić jak to zrobić bo za bardzo nie wiem. Zawsze robiło się to chyba samo bo nigdy takiego problemu nie miałem wcześniej.

Share this post


Link to post
Share on other sites

Myślę, że system-config-firewall jest bardziej przejrzyste i wygodniejsze do wyklikania (o ile serwer nie działa w trybie txt-only ;))

Share this post


Link to post
Share on other sites

Jeśli chodzi o vsftpd to czy kolega pamiętał o module ip-conntrack-ftp ?

/etc/sysconfig/iptables-config

 

# Load additional iptables modules (nat helpers)

# Default: -none-

# Space separated list of nat helpers (e.g. 'ip_nat_ftp ip_nat_irc'), which

# are loaded after the firewall rules are applied. Options for the helpers are

# stored in /etc/modprobe.conf.

IPTABLES_MODULES="ip_conntrack_ftp"

Share this post


Link to post
Share on other sites

Myślę, że <!--fonto:Courier New--><span style="font-family:Courier New"><!--/fonto-->system-config-firewall<!--fontc--></span><!--/fontc--> jest bardziej przejrzyste i wygodniejsze do wyklikania (o ile serwer nie działa w trybie txt-only <img src="http://forum.fedora.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif" style="vertical-align:middle" emoid=";)" border="0" alt="wink.gif" />)

 

Sorry że tak długo nie odpowiadałem ale nie miałem czasu. Twój sposób podziałał. Po wyklikaniu/zaznaczeniu FTP i HTTP wszystko zaczeło działać.

Share this post


Link to post
Share on other sites

Prawdę mówiąc to sposób jest @hello_world - ja tylko podałem jak można to wyklikać graficznie a nie semi-graficznie jak w "setup".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×