Jump to content
zibi743

Nietypowy Problem Z Uprawnieniami Folderów Lub Plików

Recommended Posts

Witam Was.

Gdy wchodzę do folderu Dokumenty w folderze domowym użytkownika (czyli mnie) wyskakuje mi okno z monitem o podanie hasła. Pomijam to wciskając dwukrotnie Esc. i wszystko mogę odworzyć bez podawania hasła. Trochę denerwuje mnie to okno mimo, że nie robi przeszkód w otwieraniu i używaniu plików.

Próbując rozwiązać problem, w konsoli nadałem odpowiednie uprawnienia dla folderów i plików wykonując komendę:

#chmod -R 770 home/użytkownik/Dokumenty/

Wylogowałem się i przez krótki czas było w porządku. Później "problem", raczej niedogodność zaczęła się powtarzać.

Wszystko zaczęło się od momentu gdy w konsoli ręcznie zamontowałem folder systemowy z Windowsa... Gdy wchodziłem tam z Delfina to nie było takiego problemu. "Nakręciłem" i nie mogę teraz tego odkręcić:P...

Oczywiście gdy już nie potrzebowałem folderów z windy to w konsoli je odmontowałem....735074692_Monit_o_haso.thumb.png.217646c982beb7ded9d85a5827dccfd7.png

Share this post


Link to post
Share on other sites

770 jest do katalogów, 660 jest do plików.

find /home/użytkownik/Dokumenty -type d -exec chmod 770 {} \;
find /home/użytkowink/Dokumenty -type f -exec chmod 660 {} \;

Ostrzegam, że wykonanie obydwu może zająć nawet pół godziny. Uprawnienia to jedno, ale pozostaje jeszcze kwestia właściciela plików:

sudo chown -R użytkownik:użytkownik /home/użytkownik/Dokumenty

 

Share this post


Link to post
Share on other sites

Dzięki SeeM. Właściciela plików zmieniłem w pierwszej kolejności;) Z pewnością zarezerwuję ten czas do wykonania tego zadania:)

Share this post


Link to post
Share on other sites
W dniu 6.08.2019 o 20:54, SeeM napisał:

770 jest do katalogów, 660 jest do plików.


find /home/użytkownik/Dokumenty -type d -exec chmod 770 {} \;
find /home/użytkowink/Dokumenty -type f -exec chmod 660 {} \;

Ostrzegam, że wykonanie obydwu może zająć nawet pół godziny. Uprawnienia to jedno, ale pozostaje jeszcze kwestia właściciela plików:


sudo chown -R użytkownik:użytkownik /home/użytkownik/Dokumenty

 

No właśnie. W konsoli uruchomiłem te polecenia, które mi podałeś. Niestety sytuacja się nie zmieniła....

Może w konsoli powinienem zamontować windowsowe partycje i wtedy wykonać te dwa polecenia?...

Share this post


Link to post
Share on other sites

Czasami tak się robi, gdy Windows był lub wydaje się Linuksowi, że był nieprawidłowo zamknięty. Spróbuj wejść do Windowsa, odczekaj chwilę, żeby wszystkie serwisy się uruchomiły i potem zamknij.

Share this post


Link to post
Share on other sites
2 godziny temu, WalDo napisał:

Czasami tak się robi, gdy Windows był lub wydaje się Linuksowi, że był nieprawidłowo zamknięty. Spróbuj wejść do Windowsa, odczekaj chwilę, żeby wszystkie serwisy się uruchomiły i potem zamknij.

Tak Fedorze może się wydawać... Zawsze Windows zamykam poprawnie. Nie wiem czy to może mieć wpływ ale Fedorę bootuję z przygotowanego w fdisku pendrive'a startowego (może źle się wyraziłem, chodzi mi o Gruba). Mówiąc po ludzku, zainstalowałem Grurba na pendrivie. Fedora znajduje się na innym dysku fizycznym niż Windows.

Może się mylę ale ostatnia duża aktualizacja systemu Microsoftu zepsuła mi program uruchomieniowy Fedory. Mam jeszcze zbyt mało wiedzy i musiałem Linuksa zainstalować od nowa.

Być może to dało by się zrobić przy pomocy linux rescue ale już nie miałem cierpliwości by szukać informacji na ten temat i szybciej uruchomiłem Fedorę instalując ją od nowa.

Przed tą czynnością zrobiłem kopię swoich plików z Fedory przy pomocy dystrybucji Live Manjaro Linux używając Terminala. Po instalacji i konfiguracji Fedory przywróciłem pliki (nie konfiguracyjne) z kopi zrobionej przy pomocy Manjaro. Zaraz po krótkim czasie "problem" zaczął się pojawiać....

Jednak zrobię jeszcze raz to co mi radzisz a następnie ponownie wykonam polecenia, które mi podał SeeM.

Share this post


Link to post
Share on other sites

Tak z ciekawośći zapytam: problem jest tylko z katalogiem Dokumenty? Pliki w $HOME i w innych podkatalogach $HOME możesz edytować?

Share this post


Link to post
Share on other sites

Wygląda, na to że problem jest tylko z katalogiem Dokumenty. Gdy wchodzę do innych katalogów /home... To nie pojawia się monit o hasło. Pliki w katalogu Dokumenty mogę edytować (w pozostałych katalogach też) tylko tak jak pisałem pojawia się ten monit o hasło. Daję 2 razy Esc i monit znika. Po pierwszym naciśnięciu Esc pojawia się drugi taki sam monit i po Esc znika. Hasła wcale nie muszę wpisywać, do wszystkiego mam dostęp.

Już nie wiem sam. Często kopiuję do katalogu Dokumenty pliki z partycji Windows (w Delfinie). No żeby tam się dostać muszę użyć hasła roota. Może to ma jakiś związek? Kurcze, tylko gdybam... Czy jest możliwy mały bug, jakieś niedociągnięcie?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×