Jump to content

Fedora po instalacji nie widzi mojego routera [SOLVED]


NiVFedora
 Share

Recommended Posts

Problem jak w tytule.

Uruchamiam Fedore 35 z pendriva, wszystko ok widzi moj router łączy się bezproblemowo z netem.

Gdy tylko z tego samego obrazu ja zainstaluje i uruchomię z dysku widzi wszystkie routery sąsiadów z wyjątkiem mojego.

Przy pierwszej instalcji myślałem że to kwestia tego że w kreatorze nie podałem chasła i czekałem  az uruchomię go z dysku.

więc zainstalowałem ja 2 raz.

Problem ten sam.

Myslałem że może na dysku gdzies zostały jakies ukryte pliki konfiguracyjne ktorych linux nie usuwa podczas instalacji, wiec zainstalowałem na dysku Deepin linux- tam problemu nie ma.

Potem ponownie zainstalowałem fedore. problem ten sam.

Na innym dysku podmienianym dysku mam zainstalowanego minta któreo używam od roku, żadnych problemów. Na 3 podmienianym dysku mama windowsa 10 tam tez żadnych problemów nie było.

Kiedys też  zainstalowałem Debiana, uruchamiałem kali nie było żadnych problemów z siecia.

Komputer to 10 letni Sony seria EH

Karta to:
Atheros AR9285 802.11b/g WiFi Adapter (b/g)

Router to Linksys WRT1200 AC na oryginalnym sofcie.

JEstem początkującym użytkownikiem tego systemu, wymieniłem system windows  na starym lapku  linuks minta. Po roku używania minta  chciałem poznać system lepiej i kupiłem książkę "linuks biblia", tam wszystko omawiane jest na przykładzie głównie RH /Fedory (i nieco Debiana) więc postanowiłem zainstalować ten system  ale bez neta nie da sie wiele zrobić.

 

Link to comment
Share on other sites

Jak root wydaj polecenie

nmcli device wifi list

I pokaż co zwróciło.

Może również spróbować połączyć się za pomocą polecenia

nmcli device wifi connect "SSID_TWOJEGO_AP" password "HASLO_DO_WIFI"

 

Link to comment
Share on other sites

Przychodzi mi do głowy jakiś problem z adresem MAC dlatego urządzenia się nie widzą.

Mój router na przykład jest jakiś dziwny i po przeinstalowaniu systemu na dowolnej maszynie, nie wpuszcza z niej ruchu. Trzeba go na chwilę wyłączyć i się naprawia.

Link to comment
Share on other sites

Dzięki za podpowiedzi.

Problem częściowo rozwiązany. Pozmieniałem ustawienia routera i zmieniłem kanał z 13 na 9.

Tylko wolałbym  pozostać na tym 13 kanala bo to jest jedyny pusty kanał. wszystko inne jest zapchane.

Pytanie, czemu Fedora nie widzi tak wysokiego kanału? inne distro czy win nie ma takiego problemu.

Link to comment
Share on other sites

1. iw reg get

Cytuj

w reg get
global
country US: DFS-FCC
    (2400 - 2472 @ 40), (N/A, 30), (N/A)
    (5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
    (5250 - 5350 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
    (5470 - 5730 @ 160), (N/A, 23), (0 ms), DFS
    (5730 - 5850 @ 80), (N/A, 30), (N/A), AUTO-BW
    (5850 - 5895 @ 40), (N/A, 27), (N/A), NO-OUTDOOR, AUTO-BW, PASSIVE-SCAN
    (57240 - 71000 @ 2160), (N/A, 40), (N/A)

phy#0
country 99: DFS-UNSET
    (2402 - 2472 @ 40), (N/A, 20), (N/A)
    (2457 - 2482 @ 40), (N/A, 20), (N/A), PASSIVE-SCAN
    (5140 - 5360 @ 80), (N/A, 30), (N/A), PASSIVE-SCAN
    (5715 - 5860 @ 80), (N/A, 30), (N/A), PASSIVE-SCAN

 

2. I to mi amatorowi już cos mówi :) Da sie to naprawić?

Cytuj

ls -l /etc/localtime
lrwxrwxrwx. 1 root root 38 01-23 12:30 /etc/localtime -> ../usr/share/zoneinfo/America/New_York

 

3. Nie, linuks jest swieży, nic poza mc nie doinstalowywałem.

Link to comment
Share on other sites

21 minut temu, NiVFedora napisał:

country US: DFS-FCC

Ponieważ tzw "Regulatory Domain" masz ustawione na US zamiast PL kanały 13 i 12 nie są dostępne.

26 minut temu, NiVFedora napisał:

ls -l /etc/localtime
lrwxrwxrwx. 1 root root 38 01-23 12:30 /etc/localtime -> ../usr/share/zoneinfo/America/New_York

Strefę czasową masz ustawioną na "stany" zamiast na Polskę

Strefę czasową możesz ustawić np. poleceniem

timedatectl set-timezone Europe/Warsaw

timedatectl set-timezone Europe/Warsaw

 

28 minut temu, NiVFedora napisał:

3. Nie, linuks jest swieży, nic poza mc nie doinstalowywałem.

OK. tylko to nie jest odpowiedź na moje pytanie ;)

Czy pakiet jest zainstalowany (pewnie jest) możesz sprawdzić poleceniem

rpm -q  wireless-regdb 

W tym pakiecie są odpowiednie programy które sprawdzają w jakie strefie czasowej się znajdujesz (odczytując plik /etc/localtime) i na jej podstawie ustawiają odpowiednie Regulatory Domain. Gdy strefę czasową będziesz miał ustawiona na PL kanał 13 będzie dostępny.

Link to comment
Share on other sites

3 godziny temu, NiVFedora napisał:

wireless-regdb-2021.07.14-2.fc35.noarch

To oznacza, że pakiet masz zainstalowany. Teraz wystarczy, że ustawisz odpowiednia strefę czasową, i kanał 13 powinien być dostępny.

Link to comment
Share on other sites

  • Jonshu changed the title to Fedora po instalacji nie widzi mojego routera [SOLVED]
  • Jonshu locked and unlocked this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...