Jump to content

Zagadka dysku z NTFS


 Share

Recommended Posts

Mam dysk 960 GB. Sformatowałem go na NTFS. w systemach Fedora i Sparky otwiera się bez problemów. W Ubuntu i Siduction mam informację [code]Nie można podłączyć tego urządzenia[/code]
W czym jest problem? Dlaczego tak się dzieje?
 

Link to comment
Share on other sites

Próba uzyskania dostępu do 'Backup' zakończyła się błędem: Żądane działanie zakończone niepowodzeniem: Error mounting /dev/sda1 at /media/wojtek/Backup: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error

 

Link to comment
Share on other sites

Tak, mam.NTFS-3G

Rozwiązanie tego problemu znalazłem gdzie indziej. Oto ono:

Zainstaluj sobie gnome-disk-utility i ustaw tam montowanie jak root w opcjach zawansowanych.

Teraz już wszystko działa poprawnie.

Dzięki za wsparcie. Nawet kiedy nie rozwiążemy tutaj jakiegoś problemu, cenię sobie bardzo Wasze zainteresowanie tematem. Są takie dwa Fora, na których króluje milczenie. To forum SuSe i PCLinuxOS. Nowe wątki na Forum są otoczone dostojnym milczeniem — jak w zakonie O.O Benedyktynów tynieckich.

Link to comment
Share on other sites

W dniu 21.03.2024 o 20:26, NoRobot napisał:

Tak, mam.NTFS-3G

Rozwiązanie tego problemu znalazłem gdzie indziej. Oto ono:

Zainstaluj sobie gnome-disk-utility i ustaw tam montowanie jak root w opcjach zawansowanych.

Teraz już wszystko działa poprawnie.

Dzięki za wsparcie. Nawet kiedy nie rozwiążemy tutaj jakiegoś problemu, cenię sobie bardzo Wasze zainteresowanie tematem. Są takie dwa Fora, na których króluje milczenie. To forum SuSe i PCLinuxOS. Nowe wątki na Forum są otoczone dostojnym milczeniem — jak w zakonie O.O Benedyktynów tynieckich.

Nie mam Windowsa na komputerze od jakiś 10 lat i nie jestem na bieżąco z ntfs, ale słyszałem, że ma się dobrze i nawet shadow copy obsługuje.

Byłem przekonany, że montujesz partycje z roota, lub co najmniej korzystając z sudo. Rzeczywiście dopisanie tej partycji do fstab z opcją user w kolumnie przed "0 0" by pomogło. Dobrze gada.

To by było jakoś tak:

/dev/sda1 /mnt/windows ntfs-3g rw,user,noexec 0 0

Uzytkownicy będa mogli montować i odmontowywać /mnt/windows. Nie wiem tylko, czy to już wystarczy, by mogli tam zapisywać.

Link to comment
Share on other sites

To jest dysk zewnętrzny, a nie dysk Windows. Jeśli to, co jest dla Ciebie cenne przechowujesz na dysku zewnętrznym, to w przypadku awarii systemu nic nie stracisz. System plików NTFS jest o tyle wygodny, że można w nim zapisywać pliki powyżej 4GB, a tego FAT 32 na to nie pozwala.

Link to comment
Share on other sites

3 godziny temu, NoRobot napisał:

System plików NTFS jest o tyle wygodny, że można w nim zapisywać pliki powyżej 4GB, a tego FAT 32 na to nie pozwala.

Tu bym się kłócił. Owszem NTFS daje możliwość zapisu plików powyżej 4GB, ale tą samą możliwość daje także exFAT, który ponadto jest znacznie lepiej obsługiwany w Linuksie niż NTFS. Gdyby mi zależało na kompatybilności z M$ to moim pierwszym wyborem byłby exFAT, w każdym innym użyłbym ext4, bo nie używam Windowsa (choć słyszałem, że nowe Windowsy już go obsługują out of box)

Link to comment
Share on other sites

A ja nie będę się kłócił, bo o systemie plików exFAT dowiedziałem się dopiero z Twojego posta. Przy kolejnym formatowaniu uwzględnię Twoją sugestię.

Link to comment
Share on other sites

Linux lepiej i gorzej wspiera wiele systemów plików, ale nie wszystkie potrafi naprawić w razie ich uszkodzenia, czy ponadprzeciętnej fragmentacji. Tutaj bezpieczniejszy będzie ext4 i xfs. Na maszynach z Windowsem można używać ext4, chociażby wtyczką ext4tc to Total Commamdera. A po zainstalowaniu jakiegoś Linuksa ze sklepu MS z aplikacjami, to już dowolnny uniksowy system plików jakoś się obsłuży.

Link to comment
Share on other sites

Ja nie używam systemu Windows.

Link to comment
Share on other sites

Ten dysk jest zewnętrznym dyskiem podłączonym do laptopa przez USB. Sformatowałem go na NTFS i już zapisane są na nim ważne dla mnie pliki.

Trudno mi bez utraty danych sformatować go na ext4, a problem tkwił w tym, że system nie chciał go podłączyć. Sprawa została rozwiązana, o czym Was już powiadomiłem. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...