Skocz do zawartości

Rekomendowane odpowiedzi

Witam! Po upgrade za pomoca dnf z fedory 28 na 29 ładowanie systemu kończy się na trzech kolorowych kropkach. Prosze o pomoc, bo to maszyna desktopowa do pracy. Z dokumentami i z poczta i nie wyobrazam sobie ustawiania wszystkiego na nowo. W czasie upgrade bylo wszystko ok... Zalozylem tu nowe konto, bo problemow z fedora nie mialem od baaardzo dawna. I juz dawno nie rozwiazywalem problemow... wiec prosze o instrukcje jak dla idioty.

Janusz Wo

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
10 godzin temu, Janusz Wo napisał:

Witam! Po upgrade za pomoca dnf z fedory 28 na 29 ładowanie systemu kończy się na trzech kolorowych kropkach.

Przepraszam, za chaos. Pisałem z komórki.

Po upgrade mam przy starcie systemu do wyboru jedną fedorę 29 i dwie fedory 28. Żadna nie uruchamia się. Czyli? Jakiś linux live i muszę sprawdzić, co się dzieje? Skopiować jakiś grub.conf? I poprosić o pomoc w jego naprawie? Wszystkie dostępne linuksy na komputerze to 4.19. Miałem nadzieję, że to jakiś znany błąd i zaraz ktoś coś podpowie.

Bardzo dawno nie miałem problemów z moimi fedorami. Na komputerze domowym, laptopach mam linuksy i takiej niespodzianki nie miałem od wielu lat, więc wszystko już pozapominałem. I nawet mi się to podobało ;-)

Pozdrawiam - Janusz Wo

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W jaki sposób z aktualizowałeś fedorę? Jeżeli przez dnf system-upgrade, to aktualizacja składa się z  dwóch etapów, pobierania i aktualizacji pakietów. Ten drugi, może być widoczny jako te "trzy kropki"  i jeżeli go przerwałeś to system, może nie wstać

Na ekranie z "trzema kropkami" naciśnij escape, powinien się wyświetlić terminal, są na nim jakieś komunikaty?

Przy uruchamianiu fedory w grubie, z wybranego kernela usuń opcje rhgb quiet i zobacz jakie komunikaty wyświetla fedora przy uruchamianiu.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Etapy aktualizacji wiem, są dwa, wszystko zrobiłem dobrze. Zresztą to był mój kolejny już raz i czytałem manuale i w ogóle.

Nacisnąłem esc na trzech kropkach i zobaczyłem jak się pięknie ładuje system. I wszystko się kończy na linijce [OK] Started GNOME Display Manager. I nic się dalej nie dzieje, wszystko się w tym momencie zatrzymuje. Jak uruchomię ALT+CTRL+F6 to mogę pisać. Mruga znak zachęty (taki _ ) piszę różne polecenia i nic się nie dzieje. Jak wcisnę ALT+CTRL+DEL komputer się resetuje.

Janusz Wo

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeżeli twoja karta graficzna to nvidia to spróbuj dodać do parametrów kernela  w grubie (dodajesz w taki sam sposób jak usuwasz parametry rhgb quiet)

nouveau.modeset=0

możesz również dodać do parametrów cyfrę 3, to uruchomi fedorę w trybie tekstowym, jeżeli to zadziała będziesz mógł zaktualizować system i/lub przejrzeć logi.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A jak wygląda uruchamianie Fedory 29 z płyty live? Oczywiście, gdyby się to zacięło przed powstaniem Fedory, to trzeba zgodnie ze wskazówkami sunrise wyedytować quiet->nomodeset (klawisz E po najechaniu na menu start, a po edycji Ctrl-X) i ponowić start live.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
2 godziny temu, slabypingwin napisał:

A czy nie jest łatwiej zmienić dystrybucję na inną, taką która się normalne uruchomia po zainstalowaniu? 

Tak. Myślę o ubuntu LTS ale nie w tej chwili. W tej chwili szlag mnie trafia.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Masz błąd we wpisie za .modeset=0 masz _ zamiast spacji, ale jeżeli dodałeś nomodeset to raczej nie to (nie wiem jaką masz kartę graficzną), spróbuj uruchomić tak jak pisałem wcześniej w trybie tekstowym wystarczy za pl.PL.UTF-8 dodać 3 oczywiście poprzedzając ją spacją.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nie wiem czy to będzie Twój problem. Jeżeli używasz grafiki Intela (z procesora) to raczej nie. Jakiś czas temu chyba powstał problem na styku nouveau i gnome-session-binary/gnome.Shell. W innej dystrybucji musiałem wyłączyć Waylanda dla Gnome. Dzisiaj Gnome w Fedorze bardzo się męczył i przywitał mnie ekranem "Pierwszej konfiguracji". Utworzyłem fikcyjnego użytkownika, wylogowałem się i na ekranie logowania sprawdziłem co mam do wyboru. Okazało się, że także zniknęła możliwość wyboru "Gnome on Wayland"

Wyłączenie Waylanda:
su nano /etc/gdm/custom.conf
i odhaszuj opcję #WaylandEnable=false

potem
su shutdown -r now

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Mam grafikę nvidia, ale używałem jej na sterownikach nouveau. Jedyne, co skutkuje  to w grubie

nouveau.modeset=0

i dopisanie 3 w grubie.

I już tylko loguję się do trybu tekstowego jako user. Piszę startx i wszystko startuje. Czyli pełne upokorzenie...

W międzyczasie zrobiłem gdm update. Pociągnął się nowy kernel, ale to nie zmieniło sposobu, w jaki się loguję.

Zrobiłem też

su nano /etc/gdm/custom.conf
i odhaszuj opcję #WaylandEnable=false

Ale nie wiem, czy akurat to miało wpływ na całość...

Czy mogę teraz coś zrobić żeby za każdym włączaniem komputera nie modyfikować gruba i nie logować się do konsoli i nie pisać startx?

Dzięki wszystkim za pomoc - Janusz Wo

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli masz grafikę NVIDii, to chyba jesteś skazany na ich sterowniki. W tej sytuacji chyba powinieneś zapomnieć o Waylandzie i o nouveau. Rzuć okiem na portal "if-not-true-then-false" z receptą na instalację sterowników NVIDii. Miałem podobny, choć nie tak krytyczny problem. Po twardym przełączeniu na sterowniki NVIDii wszystko jest u mnie OK. Niestety nie można zjeść ciastka i mieć ciastka.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeżeli już zalogowałeś się do fedory to zaktualizowałeś cały system czy tylko gdm? Powinieneś cały zaktualizować ponieważ w plymouth był błąd podobny do tego co spotkało Ciebie https://bugzilla.redhat.com/show_bug.cgi?id=1643302

Jeżeli pomimo zaktualizowania systemu nadal masz ten sam problem, możesz spróbować zamienić gdm na np. lightdm

W konsoli jako root wykonujesz te polecenia

dnf install lightdm
systemctl disable gdm
systemctl enable lightdm
reboot

Dopisywanie do gruba

nouveau.modeset=0

możesz sobie odpuścić, bo widać, że niczego to nie rozwiązuje.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×